gnome

Rilis wlsgnome-3.22-rc3

Kemarin lupa menambahkan entry polkit-1 ke /etc/pam.d. Sekarang sudah diperbaiki di pra-rilis rc3.

Changes:

  • elogind: Remove unneeded build options. Adding polkit-1 entry in pam.d
  • apps: Move gnome-calendar, gnome-clocks, gsound, libmediaart, and totem-pl-parser to base
  • SBo_PACKAGES.txt: Add geoclue, perl-xml-twig, and pcre2. Resorting.

Silakan diunduh:

https://github.com/w41l/gnome/releases/tag/wlsgnome-3.22-rc3

Selamat mencoba

w41lf0x Thu, 05/04/2017 - 10:39
Perbaikan Login Budgie Desktop Dari GDM

gnome-logo-hitamSetelah melakukan debug selama dua hari terhadap kegagalan login budgie-dektop melalui GDM, akhirnya diputuskan bahwa polkit milik Slackware harus diganti (dibangun ulang) untuk mendukung pam dan elogind. Hal ini diketahui dari log debug GDM yang menyebutkan bahwa gnome-settings-daemon tidak dapat memperoleh daftar sesi desktop setelah melakukan query ke elogind. Akibatnya gnome-settings-daemon mengirimkan pesan ERROR yang selanjutnya direspon oleh budgie-wm dan budgie-desktop dengan menutup sesi desktop yang sedang berjalan (SIGQUIT/SIGTERM). Inilah sebabnya jika saya login ke budgie-desktop via GDM, pada saat budgie-wm mulai berjalan, sesi desktop akan langsung selesai dan kembali ke halaman login GDM. Selalu begitu.

w41lf0x Tue, 05/02/2017 - 13:17
wlsbuild - GNOME 3.22 rc1

gnome-logo-hitamSelamat siang,

Diumumkan kepada khalayak bahwa skrip pembangun untuk desktop GNOME atau yang suka saya sebut sebagai wlsgnome telah masuk ke dalam status prarilis RC1. Wlsgnome versi RC ini digunakan untuk membangun desktop GNOME versi 3.22. Selain itu, saya sertakan juga skrip tambahan untuk membangun desktop Budgie versi 10.3 sebagai alternatif dari gnome-shell. Bukan tidak mungkin pembaca dapat memasang desktop Cinnamon yang dibuat oleh Pak Willy ke dalam instalasi GNOME ini. Rilis wlsgnome 3.22 rc1 ini memiliki alasan khusus yang tidak bisa ditawar-tawar. Rilis ini adalah sebuah keharusan, alasannya ada di paragraf berikutnya. Prarilis ini dapat diunduh melalui halaman ini:

w41lf0x Mon, 05/01/2017 - 12:29

WLSBuild Untuk GNOME 3.18

Submitted by w41lf0x on Sat, 07/30/2016 - 21:49

gnome-logo-hitamSetelah menunggu lama, akhirnya wlsbuild untuk GNOME3 bisa saya perbarui ke versi 3.18. Hal ini dimungkinkan karena Slackware 14.2 sudah mengikutsertakan gtk+3 versi 3.18.9 dalam instalasi standarnya. Beberapa dependensi dari GNOME 3.18 juga telah menjadi bagian internal dari Slackware 14.2. Artinya jika anda ingin menggunakan wlsbuild gnome3 3.18 milik saya, sila gunakan instalasi standar dari Slackware 14.2.

WLSBUILD - GNOME 3.8 For Slackware-Current

Submitted by w41lf0x on Tue, 07/02/2013 - 19:02

As you all can see in the #Slackware-current ChangeLog.txt, Slackware now can support #GNOME 3.8 out of the box although you still have to install #PAM to be able building GDM which is a requirement for gnome-shell. But as I say before, and I have tried it my self, we can build our own GNOME 3.8 on top of Slackware-current with only two non-crucial package being rebuilt. Here is my GNOME 3.8.3 in action: